Welcome! Log In Create A New Profile

Advanced

BV500 fresh start struggling

Posted by jon1977 
BV500 fresh start struggling
September 04, 2016 09:24PM
I've bought a BV500 to play with.
I've previously played with a BV507 with some success, but wanted a simpler IC for a smaller project.
I've started going through the tutorials, and can get hello world to work so all the basic wiring and coms are ok:

[www.bypic.co.uk]


but I'm struggling when I get the output test to work.
I have the latest version of BVserial downloaded today.

The file:

[byvac.com]

downloads ok, seeming to also download rookie part 1 and 2 to the device (many lines of code flash up), but when it tries to download the output_1.bas file, it errors on:
constant LED {PORTA(PORT),0}

with

RAM - output_1.bas - RAM
[output_1.bas](5) constant: LED
Error in file: output_1.bas at line 6
Line is: constant LED {PORTA(PORT),0}
------ Target reports -------
ERROR (0) <PORTA> at constant

error about 6 >><<
ERROR (0) <PORTA>

lines loaded 6
 1 Warning(s)
ERROR (0) <PORTA>ok →
-----------------------------
Done
ok
www.byvac.com, www.bypic.co.uk
ByPic MX170 2.32 (FP) Build 2016254098
Saves 0 ok cold

The input tutorial also fails on the line

io_pinmode

I note these commands are in the rookie files, and I wonder if these functions are not being saved first.

I also recall needing to use the command flsave("") to save the memory to flash, but when I do this it still says "Saves 0 OK" as if nothing is saving.
I've tried to save just the hello world program, but the same happens.

Am I doing this wrong?
What is the procedure to get programming with the BV500?

With thanks
Jon
Re: BV500 fresh start struggling
September 05, 2016 09:18AM
Jon,
the BV500 is exactly the same as the BV507 from a software point of view.

There have been some changes recently and I may not have brought all of the tutorial material up to date yet for example rookie 3 uses io_pinRole not io_pinMode.

However, there is now a newer way of doing things, most of the site is up to date, sorry about the tutorial. In the new method GONE is rookie, it is not needed. It has been replaced with specific library files which are included in the top of the current file thus:

Quote
// #include http:// www.byvac.com/mBlib/flb/Library/2016/lib_io.bas

It is a much better way of loading library files as it is more 'fine grained' rookie would contain a lot of functions that would never be needed. Also the #include can be included several times in different files but will only be included once. This also means that the script file is not needed anymore.

I would recommend an upgrade.

You will need the latest version of BVSerial 17 and also version 2.31 2016...98.

Start with the IDE page for a quick introduction, but apart from the above it works in much the same way.
Re: BV500 fresh start struggling
September 05, 2016 07:00PM
The tutorial has now been updated

5 September 2016
Re: BV500 fresh start struggling
September 05, 2016 08:28PM
Cheers, that all seems to work,
A couple of typos:

// #include "[ww.byvac.comm];

has too many m's on the .com and is missing a w on the www

jon
Re: BV500 fresh start struggling
September 06, 2016 09:47AM
Thanks, fixed
Sorry, only registered users may post in this forum.

Click here to login