Welcome! Log In Create A New Profile


problem update (Internet of Things)

Posted by gulik154 
problem update (Internet of Things)
February 01, 2015 01:04AM
hello has anyone a solution

I use IoT kit
I have update to ESP8266_b.bas

function server ap 4 \ 9 works well
Station mode 5 also good
function 11 \ 8 date and time info site google fine
only the window with temperature control and LED does not

I've read reports IoT (Internet of Things) of Elfont but does not work for my
several times used flclear (0) and new link
[http://byvac.com/mBlib/flb/Library/wifi/ESP8266_b.bas] installed
but still no control window

sorry for the english writing
it can read and, if necessary, google !!
Re: problem update (Internet of Things)
February 01, 2015 09:28AM
Which doesn't work?
Client(2) using pushingbox

Try and be more specific, IP address, what you are using for the host, Windows, tablet laptop etc.
Re: problem update (Internet of Things)
February 01, 2015 08:59PM
hello Jimeer
I use (lot) Kit Included temp sensor \ LED and power module
followed the manual
am running into the same problem a few others That Seem to have ie I can not get the web page (LED and DHT11 items) to respond in upkeep of the two modes detailed in the instructions.
Other functions (8 and 11) do work OK
I have the new update ESP8266_b.bas] installed but does not solve anything
I first used flclear (0)
then copy update ESP8266_b.bas /in PSPad use script url \ F4 or send any scripts to ByPic

This tread followed you and Elfont
Re: IoT (Internet of Things)
November 18, 2014 1:19 PM

the device (laptop, phone, etc.) connects to ESP8266, but the board resets When The device tries to access; I'm Assuming it's a reset - in the serial window When I get this ACCESSING
(See respond the blue LED on board) within 1 second message on screen

ready ..
Characters recieved 6
318: GET / H ch = 0
Page has been recieved [/]
Text input buffer 254 Allocated Baud 115200

Client (2) using pushingbox have not tried since I first want to solve the 1st problem

waiting for a suitable solution
Sincerely JM Gulik

Edited 1 time(s). Last edit at 02/01/2015 09:09PM by gulik154.
Re: problem update (Internet of Things)
February 02, 2015 08:43AM
ok. you are having problems setting up a server as "Setting up a Server (1)"

It looks as though you are nearly there. As you don't say I will assume that you are using Windows so, open a command window (start and type cmd) then ping

What is the result?

Re: problem update (Internet of Things)
February 02, 2015 02:27PM
hello Jimeer
my first step
the kit attached see him list different available stations
with ip address
CDM with a ping to this number

ping answer with 32 bytes of data

destination host is unreachable.
destination host is unreachable.
destination host is unreachable.

Ping statistics for
packages: Sent = 4, Received = 0, Lost = 4
(100% loss)

2nd test done the same thing only with mobile
answer timeout
see it reacting blue LED
Re: problem update (Internet of Things)
February 02, 2015 06:49PM
I forgot to ask, do also ipconfig and then what is the IP address of the Wireless LAN adapter?

Re: problem update (Internet of Things)
February 02, 2015 08:43PM
hello Jimeer
at this ip address of Wireless LAN adapter
Re: problem update (Internet of Things)
February 03, 2015 08:54AM
(** Reminder this is for the "Setting up a Server (1)" **)

That is the problem.
The IP address must be on the same network for communication to take place,thus 192.168.4.nn The nn doesn't matter the important bit is the first three digits which must match. The reasons for this are:

1) Your laptop is NOT connected to the ESP8266 but some other wifi device (obviously otherwise it would have the correct IP address, given to you by the ESP8266).

2) You have not waited long enough for the ESP8266 to give the laptop an IP address, it can take sometimes 2 minutes.

3) Your lap top has re-connected back to its preferred wifi automatically, Android devices do this mostly.

4) You have a firewall that will only allow specified MAC addresses.

I can't help with any of these as they are specific to the device you are using. However I can re-iterate on how this mode works:
1) The ESP8266 is set as an Access Point
2) You connect your laptop to that access point by going into the wifi settings(wireless networks etc.) and choosing the ESP8266 as the wifi adaptor
3) The ESP8266 will then give you an IP address which begins with 192.168.4 This can be checked using ipconfig, this may take a minute or two
4) Only then can communication take place in this mode "Setting up a Server (1)"

Hope this helps
Sorry, you do not have permission to post/reply in this forum.