Welcome! Log In Create A New Profile


Cannot get C plug ins or C to run

Posted by noddy 
Cannot get C plug ins or C to run
July 09, 2012 08:56AM
Tried 2 ways of getting C code running.
1) I was using the 1st of 4 examples provided on the web site to flash the LED. The code from the web site worked fine if downloaded to the PIC without touching the compiler. I went to recompile the code (without changing anything) to make sure I had a stable base, and it said it was successful, but when I loaded it to the PIC, it wouldn't run. (MPLAB IDE version 8.86.00, PIC32MX340F512H)

2) Tried using the plug in method from basic. Basic doesn't seem to understand the command "plugin to" and I just get a syntax error. I understand the C code and struct definition etc. I just cannot get the code into the device. BV513 basic v2.31 loaded.

Any thoughts?
Re: Cannot get C plug ins or C to run
July 09, 2012 10:49AM
If you downloaded the C examples last week then they will only work with Version 1 of the C32 compiler. The new files will only work with C32 Version 2.2 and boot loader version 2 so this applies to:
BV523 & BV513_V2

If you have BV513 with boot loader 1, this can be upgraded free of charge to boot loader 2 if you send it back to:
PO BOX 4049
S36 6WP
with a covering note.

*** How to tell which boot loader you have ***
Using the older version of BV-COM here : [doc.byvac.com]
(Doesn’t work with BV_COM2)
Press reset and within 0.5 second press the ‘\’ key.
1) If a boot loader menu comes up with choices a,b,c etc. then its boot loader 1
2) If ‘D’ is being constantly sent out then its boot loader 2.
Re: Cannot get C plug ins or C to run
July 14, 2012 07:39PM
Thanks for the quick turn around on the boot loader update. Unfortunately I find myself in the same situation. Have successfully downloaded basic and this still runs, then re-downloaded BC513_V2_c project 1 and the LED flashes again so great. However opened the project and without touching anything, recompiled and linked, and it said successful but it still won't download. Checked for the differences in the ld file that was automatically loaded and could see the rem'ed out KEEP and new Keep line. I did note the compiler is v2.02 rather than 2.2 you state above. Is this a typo as I cannot see a v2.2 on the MPLAB web site? Still stuck anyway!
Re: Cannot get C plug ins or C to run
July 14, 2012 07:57PM
Ignore my last message. Its now compiling and downloading after I read one of your other posts and compiled the _2_mplab8 version. Thanks for your help.
Sorry, only registered users may post in this forum.

Click here to login