Welcome! Log In Create A New Profile


Project built with pic32 compiler v2.02a won't work

Posted by nemo888 
Project built with pic32 compiler v2.02a won't work
July 13, 2012 03:41PM
Hello all,

I have recently bought a bv513 mini board (received 2 days ago) from ByVac, and just managed to load the blinking led project to the board, using BV_COM2 (release 1.31) and one of the projects provided fr the v2 bootloader.

After loading the .hex fiel the led started blinking, but than I just built the project again with the tools I have installed and though it builds with no error and the bootloader seems to load the project properly (same steps as when it worked), well nothing happens on the led.

I don't know which was the c32 version the original project was built with, but I think the problem has something to do with me having built the project with pic32 compiler v2.02 (the only I found on Microchip's page).

Could the location where the compiler was installed have anything to do with this? I use windows 7 and the default is in "program files x86" folder, which is different from the previous location of the compiler that was used for the original project (the locations appear when you build the project, since it has been previously built on a different computer).

Well I hope that explains it. I hope someone ca help jejee..
Re: Project built with pic32 compiler v2.02a won't work
July 14, 2012 01:22PM
<<This is the C Programming examples>> found here:

The project will successfully build if using MPLAB-X and compiler C32 V2.02. The trick is to get the linker script file correct, if you open the project using MPLAB-X then in the Projects window under the ‘Linker Files’ there will be this file “elf32pic32mx.ld”. Because a boot loader is used the location of the C program is moved up from where it normally resides and it is this file that controls it.

If using MPLAB V8 it needs to know the correct linker file as the default one will produce a hex file in the wrong location to run from the boot loader. I suspect that you have gone into the “BV513_V2_compiler_2_mplabx” folder and double clicked on the ‘proj1.mcp’ file that has launched MPLAB 8 rather then MPLAB-X

There is now another folder in the zip file called “BV513_V2_compiler_2_mplab8” which will work under MPLAB version 8, simply double click the ‘proj1.mcp’ file in this folder if you are using MPLAB-8. Make sure that under the Linker files, this is included “elf32pic32mx.ld”. It should be there if proj1.mcp is used.
Re: Project built with pic32 compiler v2.02a won't work
July 14, 2012 02:55PM
Hy jimeer!

Thanks for your reply, I finally have it working. What actually happened was that I had downloaded the archive with the projects before project one had been updated, that is, I had "BV513_V2_compiler_2_mplabx" but the other one was "BC513_V2_compiler_1_mplab8", and that's why it wasn't working. After I downloaded the new archive with the right projects, it worked just fine >:D<

Thanks a bunch!:)o
Sorry, only registered users may post in this forum.

Click here to login