Fonts, loding & use
October 29, 2013 05:55PM
Hi Jim

1 ) I have doubts about the file * . Bff produced by CodeHeads because almost all have the size of 193kb . Only your LCDMono Normal30.bff have 385KB . When I use CodeHeads choose the type of font , I set height and width and push the save button. It seems simple.

2) When I load *. Bff to RAM it flows regular but when I try to write nothing appears on the LCD
"
| ByPic Version 2.08
| Saves 0 |
| BV523 Serial# 201310020
| |
| Documentation www.bypic.co.uk |
| |
| Copyright Jim Spence 2013 |
======================================
0:/ ok difont("verd30.bff")

0:/ ok ditext("lhifwnl")
0:/ ok ditell(1)

1 0:/ ok

0:/ ok

0:/ ok ditext(" Verdana30.bff ")

0:/ ok difont("0")

0:/ ok ditext(" default ")

0:/ ok dicls(65535)

0:/ ok ditext(" test")

0:/ ok difont(verd30.bff")
ERROR (0) <verd30.bff"> undefined function or variable
ERROR (28) expecting )

0:/ ok difont("verd30.bff")

0:/ ok dihome()

0:/ ok didown(3)

0:/ ok ditext(" Verdana30.bff ")

0:/ ok difont("0")

0:/ ok ditext(" default ")

0:/ ok
"
Then set de default font and ditext flow normal.

Please give me clues on how to:
create the correct font from CodeHeads

loading correctly from the SD card to RAM

and how to use 2 fonts alternating

Fernando Claro



Edited 1 time(s). Last edit at 10/30/2013 07:27AM by jimeer.
Re: Fonts, loding & use
October 30, 2013 07:34AM
you will find the information you are looking for here:
www.bypic.byvac.com - getting started
Re: Fonts, loding & use
October 31, 2013 09:45PM
Hi Jim

Some thing is wrong
I can't loading any font.
I read "getting started" once more
and create the binary file *.bf from *.bff
I put it on SD and ..

"...
----A 2013/10/31 21:02 8459 VERDAN~1.BF
----A 2013/10/31 20:58 14449 LCDMON~1.BF
----A 2013/10/31 20:23 105 TESTE1.BAS
----A 2013/10/31 21:02 8459 VERDAN20.BF
----A 2013/10/31 21:03 8459 VERDAN~2.BF
----A 2013/10/31 20:59 8459 LUCIDA~1.BF
----A 2013/10/31 20:59 8459 LUCIDC20.BF
----A 2013/10/31 21:01 8459 VERDAB16.BF
32 File(s), 4686895 bytes total
1 Dir(s), 36405248 bytes free

0:/ ok fload("lcdmon~1.bf")

--- start of P_fload ---
ERROR (0) <7D> undefined function or variable at fload

0:/ ok

0:/ ok

0:/ ok fload("lcdmon~1")

--- start of P_fload ---

67 0:/ ok

0:/ ok ditext("Text Sample")
0:/ ok

0:/ ok ...
"

at second time write on screen, but with initial font

I tried with others fonts, but results are the same.

I suspect there are some thing wrong with this HW.

Please, can you give some clues to use other font ?

Fernando Claro
Re: Fonts, loding & use
November 01, 2013 07:23AM
hello,
if you want a reply to your posts then you need to be more specific. The question you have posed above does not make any sense to me, I cannot tell what problem you are having other than something to do with fonts. I have no idea why you are using fload, it is nothing to do with fonts and is not in the getting started guide.

I suggest that you simplify the problem to a specific item and then clearly state exactly what the problem is. This may better help you understand the problem yourself. Using fonts on the BV523 is http://www.bypic.byvac.com/index.php/BV523_Starting there is no point in repeating the text here. I also gave the link in the previous post.
Re: Fonts, loding & use
November 06, 2013 11:18AM
Hello
Positive

Ok now I use many fonts!
My mistake was to consider fonts must be loaded on RAM.
Now I understand the fonts must be on SD and only call difont("FontName.bf")
I tried to run fp2c.exe but no run on win7, for now never mind.

In my opinion read the rookie files is the best way to understand the fonts.

Thanks Jim
Sorry, only registered users may post in this forum.

Click here to login