Welcome! Log In Create A New Profile

Advanced

BV508 add SD card & Firmware not working

Posted by kev1953 
BV508 add SD card & Firmware not working
June 22, 2015 06:51PM
Hi Jim
Sorry am updating as I go

I have at last looked at the BV508 with ESP8266, it seamed the best use of this is with a SD card fitted.
So added the hardware, a BV410-A
Pin 1 CS to CS B14
Pin2 MOSI to DI B5
Pin3 Gnd to Gnd
Pin 4 3.3v to 3.3v
Pin 5 SCK to CLK
Pin 7 MISO to DO B5

Is this correct?, on power up the SD LED flashes a number of times, on doing a reset it flashes once
but it will not see a card also will not show the 0:/ ok prompt

I have updates the firmware as below
OK found it did not like 2 of the 3 SD cards only one will work, now I have the problem of re-installing the software for the ESP8266 etc
My Scripts in PSpad does not have an Open URL in clip ?
Sorted in the end by coping file into PSpad V4.5.8

Great now my menu has not got Option 9, Found version of menu with all options
but now will not load, who said life is simple ??
Will have to start again
Found correct Menu at [www.bypic.co.uk]
It connects and sends the test page, but no page shows up on Tablet ?

I have 2 BV508, the 2nd board without any mod works fine, I also have the IoT kit
Only one of the ESP8266 will display the SSID in option 3, the other 2 display can connect to ""
But all 3 work OK ?

So I am still at the point where the BV508 with SD works it sends the web page but will not display on the device, so something still
incorrect with the SD firmware or the re-installed ESP8266 HELP

OK Started again loaded PB1_MX170_FP.bin (i.e. not PB1_MX170_FP_SD.bin) so NO SD card support
then re-installed ESP8266, all works fine.
So some thing in the SD card support bin file messing things up ?
Hope to get some feed back !


Many thanks

System cold start
--------- Hardware Detect ----------
RTC start attempt ok
MMC status=1
SD Card HW initialised ok
Mounting SD 0 result 0
Mounting SD 1 result 0
======================================
| ByPic Version 2.30 (FP)
| Saves 0 |
| MX170 Serial# 201525067



Edited 6 time(s). Last edit at 06/23/2015 04:30PM by kev1953.
Re: BV508 add SD card now working
June 25, 2015 04:19AM
After a lot of messing about, got it working using info from this page
[www.bypic.co.uk]
Had to load each file on it's own, would not load in off card, then strip back to get it running

To send "mypage" you create a web page and save to SC card in directory /web
you add a function for each new page i.e. (note TEMPFILE$ must be uppercase)

function mypage()
create_tempFile("/web/mypage.htm")
send_page(chan,TEMPFILE$)
return 0
endf

then in browser type in URL plus /mypage
if all works then mypage is sent to you device

Note <p>The temperature is <? bypic getTemp ?></p>
don't enter the space, i.e. <?bypic getTemp?></p>

Easy once you know what you are doing,
Thanks to Jim for great products and all the info

Many thanks



Edited 2 time(s). Last edit at 06/29/2015 04:14AM by kev1953.
Sorry, only registered users may post in this forum.

Click here to login